Skulltrail / Vista 64-Bit problem?


I recently installed a new CPU in my Skulltrail motherboard giving it 2 Quad Core CPU's, and in the Device Manager on Vista I can see 8 Cores listed under Processor all of which are
Intel(R) Xeon(R) CPU E5472 @ 3.00GHz.
However in Task Manager I can only see 4 Graphs showing and also the programs I have on my computer can also only see 4 cores.
What is causing this and how can I fix it.
I run Boinc and saw Rob Williams "
Intel Skulltrail Enthusiast Platform Preview" on
so I know that it is possible to run Boinc with all 8 cores but I'm stuck as to how to do it. Is it a bios setting that needs altering or is it something in Windows Vista that is messing up and not notifying the appropriate place that there is an extra CPU installed?
Any help would be appreciated, thanks.
Last edited:


Techgage Staff
Staff member
If this was XP I'd suspect it was because of how the boot.ini file was configured. But because Vista does away with that the only thing I could suggest is to check if the second processor somehow got disabled in the BIOS. Also make sure your motherboard is using the latest BIOS.


Apparently Vista replaces the Boot.ini file with BCDEditor which is a Command Line thing, info on it here...

However after typing in bcdeditor.exe and then typing in "something that ive forgotten" followed by "/?" (without quotes) to get the commands that are available in there, what comes up next is over my head and I don't know what to do with the editor in order to make it see the other cores, if that is in fact the correct place to make the PC see them.

Oh and last time I installed the latest Bios my pc wouldnt start at all and I had a hell of a job getting the original back into the Bios again.
Last edited:


Solution Found

Well after all my searching for a solution online and trying to understand the BCDEdit.exe program from the Command Line (which I have hardly ever had to use in the past) I finally found a solution to the problem.
It turned out to be an extremely embarasing thing that I hadn't done correctly when I tried to use the program VistaBootPRO 3.2 in order to get some kind of GUI interface to do the work for me to the BCDEdit.exe thing.
On the Advanced BCD Registry Settings tab there is a blank Selection Box on the lower part of the window where your supposed to "Select the Windows Vista or Longhorn entry from the list below to begin."
Not having noticed those words the first, second or even third time I opened the program I had neglected to actually choose my OS that I wanted the VistaBootPRO to fix and so looking all over the program didn't actually produce any useful information.
Finally after involving hundreds of people on the Seti site and a few dozen more on a couple of other forums I opened the program for the fourth time and notice my error.
Choosing the option "Microsoft Windows Vista" from the drop down menu instantly changed the details below the choice and showed me that the "CPU and Memory Options" had a tick in the "Limit CPU's" option and was set to "4".
I could have shot myself for being so stupid as to not have noticed it yesterday when I downloaded and installed the program.
I then took the tick out of the "Limit CPU's" option and rebooted and hey presto instant access to all 8 CPU's.

I would like to thank all the people on the Seti site who did most of the work in fixing this problem, and a couple of other forums I tried to get help on, by suggesting things that might have been causing the issue. I certainly would never have figured it out from the available help on Google as there was so much there that putting in any kind of search for this gave so many other possible things that it was nearly impossible to find anything useful.
I shall post this on the other couple of forums I used too in order to help anyone else that finds themselves in this situation.
Once again thanks to everyone concerned for all your help. I bow to your superior wisdom.
A very relieved BorgVampire